clear
{{language.name}} No language found.
swap_horiz
{{language.name}} No language found.
search
TRANG TRANG 2019-01-06 22:40 2019-01-06 22:40:01 link permalink

**New year, New Tatoeba**

We will soon release the new version of Tatoeba and I wrote a blog post about it:
https://blog.tatoeba.org/2019/0...w-tatoeba.html

Please continue testing the dev website to ensure that the code migration[1] didn't break anything important for you! Thank you!

---
[1] https://tatoeba.org/eng/wall/sh...#message_30964

{{vm.hiddenReplies[31066] ? 'expand_more' : 'expand_less'}} hide replies show replies
Ricardo14 Ricardo14 2019-01-07 00:07 2019-01-07 00:07:13 link permalink

Tatoeba is growing up! Let's Tatoeba!!!

Rockaround Rockaround 2019-01-07 09:57 2019-01-07 09:57:39 link permalink

Very nice! Congratulations to everyone involved in development and QA.

TRANG TRANG 2019-01-19 20:57 2019-01-19 20:57:17 link permalink

The new Tatoeba is here :)

Please report any issue in this thread. I'm not expecting everything to work perfectly right off the bat, but hopefully there won't be any major issue that requires to revert back.

{{vm.hiddenReplies[31172] ? 'expand_more' : 'expand_less'}} hide replies show replies
PaulP PaulP 2019-01-19 21:19 2019-01-19 21:19:04 link permalink

First small issue: we used to see only translations in our "profile languages". Now we see them all.

{{vm.hiddenReplies[31173] ? 'expand_more' : 'expand_less'}} hide replies show replies
TRANG TRANG 2019-01-19 21:25 2019-01-19 21:25:14 link permalink

I would need a screenshot to better understand.

{{vm.hiddenReplies[31174] ? 'expand_more' : 'expand_less'}} hide replies show replies
PaulP PaulP 2019-01-20 07:30 2019-01-20 07:30:18 link permalink

https://www.dropbox.com/s/l18xs...30.23.png?dl=0

If I choose a random sentence, I see transactions e.g. in Chinese, although Chinese is not in my list of profile languages.

As soon as I change something on that page, e.g. I link two translations, then all the other languages disappear and I see only translations in my "profile languages"

https://www.dropbox.com/s/5hpv3...31.19.png?dl=0

It's not a big issue. But it was different before the upgrade.

{{vm.hiddenReplies[31181] ? 'expand_more' : 'expand_less'}} hide replies show replies
PaulP PaulP 2019-01-20 09:18 2019-01-20 09:18:37 link permalink

Now I see that it is not such a small issue. If you have a sentence with a few hundred translations, it takes a lot of time to scroll to the comments section!

TRANG TRANG 2019-01-20 13:35 2019-01-20 13:35:19 link permalink

Thank you, I have created an issue: https://github.com/Tatoeba/tatoeba2/issues/1741

Note that for sentences with a lot of translations, there is an option to expand/collapse translation: https://screenshots.firefox.com...gu/tatoeba.org

shekitten shekitten 2019-01-19 21:30 2019-01-19 21:30:17 link permalink

I'm unsure how to select a license. I would personally prefer to use CC-Zero from now on, but I don't see an option for selecting.

{{vm.hiddenReplies[31175] ? 'expand_more' : 'expand_less'}} hide replies show replies
TRANG TRANG 2019-01-19 21:36, edited 2019-01-19 22:44 2019-01-19 21:36:36, edited 2019-01-19 22:44:29 link permalink

I haven't yet published the instructions about it :)

It's a new feature and will have restricted access at first. Basically an admin (=myself) will have to grant you permission.

But I've noted that you want to use CC0. I'll contact you back later about it.

Edit: I've added an article in the wiki:
https://dev.tatoeba.org/eng/lic...h_my_sentences

odexed odexed 2019-01-20 02:24, edited 2019-01-20 02:36 2019-01-20 02:24:39, edited 2019-01-20 02:36:42 link permalink

I got this error while trying to search for "не попрощавшись" in Russian https://tatoeba.org/eng/sentenc...rom=und&to=und
https://i.imgur.com/QpjOtjR.png

{{vm.hiddenReplies[31177] ? 'expand_more' : 'expand_less'}} hide replies show replies
TRANG TRANG 2019-01-20 04:31 2019-01-20 04:31:52 link permalink

Debug mode was actually enabled. I turned it off. The warning should no longer appear.

soliloquist soliloquist 2019-01-20 04:39, edited 2019-01-20 06:19 2019-01-20 04:39:36, edited 2019-01-20 06:19:57 link permalink

Sentence owners are not shown on comments.

https://tatoeba.org/eng/sentence_comments/index

Previously, that was only the case with orphan sentences.

{{vm.hiddenReplies[31180] ? 'expand_more' : 'expand_less'}} hide replies show replies
TRANG TRANG 2019-01-20 13:23 2019-01-20 13:23:52 link permalink

Indeed. There's an issue for this: https://github.com/Tatoeba/tatoeba2/issues/1736

It will be fixed in next week's update.

fjay69 fjay69 2019-01-22 12:09 2019-01-22 12:09:13 link permalink

Adding alternative script to japanese sentenses causes error : The requested address '/eng/transcriptions/save/4561996/Hrkt' was not found on this server.

{{vm.hiddenReplies[31201] ? 'expand_more' : 'expand_less'}} hide replies show replies
TRANG TRANG 2019-01-22 13:19 2019-01-22 13:19:46 link permalink

The transcription feature has not been fully migrated yet. You will have to wait for a few more weeks for it to be available again.

PaulP PaulP 2019-01-23 08:47 2019-01-23 08:47:52 link permalink

I'm not sure if it is related to the new update, but the problem appeared just now. When Tatoeba sends me a message with links in it, only the short links starting with # are clickable, the long links starting with https:// are not.

I use Thunderbird on Mac. I didnt try yet to change my mail reader.

Here is a screen copy:

https://www.dropbox.com/s/rcti7...41.36.png?dl=0

{{vm.hiddenReplies[31210] ? 'expand_more' : 'expand_less'}} hide replies show replies
TRANG TRANG 2019-01-23 09:33 2019-01-23 09:33:44 link permalink

I created an issue: https://github.com/Tatoeba/tatoeba2/issues/1754
It was not like this before.

Hybrid Hybrid 2019-01-20 16:31 2019-01-20 16:31:41 link permalink

Hi, is it just me or has autocompletion for tags disappeared?

{{vm.hiddenReplies[31187] ? 'expand_more' : 'expand_less'}} hide replies show replies
TRANG TRANG 2019-01-20 16:40 2019-01-20 16:40:07 link permalink

It's not just you. It's been reported: https://github.com/Tatoeba/tatoeba2/issues/1744

Thanuir Thanuir 2019-01-21 11:50 2019-01-21 11:50:47 link permalink

I am trying to add a vocabulary item ("omegn" to norsk bokmål, not a native language for me) but, after clicking "add", the process starts but does not seem to finish in finite time. There is no error message either.

{{vm.hiddenReplies[31190] ? 'expand_more' : 'expand_less'}} hide replies show replies
TRANG TRANG 2019-01-21 17:00 2019-01-21 17:00:56 link permalink

This may be cache issue. Try to clear your cache and see if it still happens.

{{vm.hiddenReplies[31194] ? 'expand_more' : 'expand_less'}} hide replies show replies
Thanuir Thanuir 2019-01-24 15:37 2019-01-24 15:37:33 link permalink

Clearing the cache did not help.

{{vm.hiddenReplies[31214] ? 'expand_more' : 'expand_less'}} hide replies show replies
TRANG TRANG 2019-01-24 23:38 2019-01-24 23:38:07 link permalink

Do you have the same problem on another browser? Do you have the same problem on the dev website: https://dev.tatoeba.org?

{{vm.hiddenReplies[31215] ? 'expand_more' : 'expand_less'}} hide replies show replies
Thanuir Thanuir 2019-01-25 07:25 2019-01-25 07:25:28 link permalink

The problem repeats on:
1. Linux, Firefox, used Tatoeba before.
2. Windows, Firefox, used Tatoeba before, different physical computer.
3. Same machine as 2 but with Edge, which I use extremely rarely and have not used Tatoeba on, as far as I remember.

I have not tried the dev website yet. I might get to it at some point.

It would be interesting to know whether other people can use the feature or not; if it is only me, spending too much effort on solving the problem seems uncalled for.

{{vm.hiddenReplies[31218] ? 'expand_more' : 'expand_less'}} hide replies show replies
PaulP PaulP 2019-01-25 08:37 2019-01-25 08:37:44 link permalink

I can't reproduce the problem. It happens to all words? Or only in norsk bokmål?

{{vm.hiddenReplies[31219] ? 'expand_more' : 'expand_less'}} hide replies show replies
Thanuir Thanuir 2019-01-25 08:44 2019-01-25 08:44:18 link permalink

I could add a word in English, in Finnish, and another word in bokmål. I could also add the problematic word "omegn" as a Danish word to my vocabulary.

So the problem seems to be specific to the word "omegn" in the language "Norsk bokmål".

{{vm.hiddenReplies[31220] ? 'expand_more' : 'expand_less'}} hide replies show replies
TRANG TRANG 2019-01-25 11:13 2019-01-25 11:13:12 link permalink

I was able to add "omegn" in Norsk bokmål. You can see it in my vocabulary list: https://tatoeba.org/eng/vocabulary/of/TRANG

Can you try to add again the vocabulary, but with the "Network" tab of the Developer tool open (shortcut on Firefox: Ctrl + Shift + E).

Send me a screenshot of the "Headers" and the "Reponse" for the POST request.

For me it looks like this:
https://gyazo.com/23cf1bc5feb84b910688302e197531f4
https://gyazo.com/fe0c35326c51da026a0644f65a86ae7b

TRANG TRANG 2019-01-27 14:13, edited 2019-01-27 14:17 2019-01-27 14:13:57, edited 2019-01-27 14:17:59 link permalink

I found out the issue: this happens when you try to add a vocabulary that you've already added.

I created a GitHub issue for this: https://github.com/Tatoeba/tatoeba2/issues/1758

{{vm.hiddenReplies[31232] ? 'expand_more' : 'expand_less'}} hide replies show replies
Thanuir Thanuir 2019-01-27 14:27 2019-01-27 14:27:25 link permalink

I tried with some other words I already have in the vocabulary and this seems to be true. Thanks.

belkacem77 belkacem77 2019-01-21 13:22 2019-01-21 13:22:19 link permalink


Thanks for all job you did.
We are testing while browsing the site.
Thanks for everyone.

Hybrid Hybrid 2019-01-26 13:57 2019-01-26 13:57:57 link permalink

I got "An Internal Error Has Occurred" from the random sentence on the homepage. Also, I'm still getting logged out randomly and got a message about a CSRF token.

{{vm.hiddenReplies[31225] ? 'expand_more' : 'expand_less'}} hide replies show replies
TRANG TRANG 2019-01-26 15:08 2019-01-26 15:08:44 link permalink

I would need a bit more details about what you were doing before the errors occurred.

{{vm.hiddenReplies[31227] ? 'expand_more' : 'expand_less'}} hide replies show replies
Hybrid Hybrid 2019-01-26 16:17, edited 2019-01-26 22:42 2019-01-26 16:17:11, edited 2019-01-26 22:42:48 link permalink

I had been logged out of Tatoeba and was trying to log back in. Instead of a random sentence, the homepage (tatoeba.org) displayed an Internal Error message. Then when I tried to log in it displayed the other error. I tried to log in again and it work.

I think maybe it's just because sometimes Tatoeba slows down and goes crazy :)

It happened again:
Random sentence on the homepage (not logged in):
"An Internal Error Has Occurred

Error: An Internal Error Has Occurred."

Login:
"CSRF token mismatch.

Error: The requested address '/eng/users/check_login?redirectTo=%2F%3Flang%3Deng' was not found on this server."

{{vm.hiddenReplies[31228] ? 'expand_more' : 'expand_less'}} hide replies show replies
Hybrid Hybrid 2019-01-27 04:00, edited 2019-01-27 04:03 2019-01-27 04:00:35, edited 2019-01-27 04:03:23 link permalink

I found a new error. When I look at https://tatoeba.org/eng/users/show/50371, in the comments section, the sentences appear to have been deleted and have no flag (? symbol flag).

For example:
"Sentence #7752239
sentence deleted
unknown
Hybrid
Hybrid 13 hours ago

stoup: a flagon or beaker for drink.
quaigh: shallow drinking cup, typically made of wood and having two handles. (Scottish)"

But sentence 7752239 has not been deleted. https://tatoeba.org/eng/sentences/show/7752239

{{vm.hiddenReplies[31230] ? 'expand_more' : 'expand_less'}} hide replies show replies
TRANG TRANG 2019-01-27 15:07 2019-01-27 15:07:48 link permalink

The errors on the "Latest activities" page was reported by brauchinet: https://github.com/Tatoeba/tatoeba2/issues/1757

TRANG TRANG 2019-01-27 15:11 2019-01-27 15:11:07 link permalink

Are you really logged out randomly or does it happen on specific actions? Even if it seems random, try to remember what you were doing exactly before being logged out. Every detail can make a difference in figuring out the problem.

Aiji Aiji 2019-02-01 14:25, edited 2019-02-02 03:06 2019-02-01 14:25:15, edited 2019-02-02 03:06:47 link permalink

The request has been black-holed

Error: The requested address '/fra/sentence_comments/save' was not found on this server.

I'm not sure when this happens. I think it was when I posted a comment. The comment was not saved.
EDIT: It happened on the Wall as well, just now :(